Sponsor Products
Rocky 9.2 pcoip software client unable to connect due to authentication issue.
posted by Trevor M.  on July 20, 2023, 3:38 p.m. (4 months, 10 days ago)
0 Responses     0 Plus One's     0 Comments  


We're migrating to Rocky 9 and we're currently stuck testing, because pcoip cannot connect to a rocky 9 machine.

I just tried the new beta 23.08 version which officially supports Rocky 9.2, but the problem appears to be the same which is a user authentication error as it seems that PAM authentication appends our domain to the user name and when it's forwarded to our Domain Controller it doesn't recognize the account. So perhaps this is an SSSD PAM problem in rocky 9 and not specifically pcoip.

I tested on Rocky 8 and it worked fine.

Is anyone aware of changes that happened between redhat 8 and redhat 9 for authenticating with SSSD?

when pcoip is installed it creates 2 PAM files which appear to be identical between Rocky 8 and 9.

Any help would be greatly appreciated!

Thank you.


Thread Tags: